My application exe behaves like not instrumented to use DevExpress.libz ?

Apr 19, 2014 at 11:38 AM
Hi I am new to merging and libz tool,

I have tried to use it to merge devexpress dlls using this:
libz add --libz DevExpress.libz --include DevExpress*.dll --codec deflate --move
ibz instrument --assembly meds_app.exe --libz-file DevExpress.libz


when I executed meds_app.exe on another pc it behaved like that meds_app.exe is not instrumented at all to use DevExpress.libz ?
and I had this exception:
System.Windows.Markup.XamlParseException: The method or operation is not implemented. ---> System.NotImplementedException: The method or operation is not implemented.
at System.Windows.Baml2006.Baml2006SchemaContext.ResolveBamlType(BamlType bamlType, Int16 typeId)
at System.Windows.Baml2006.Baml2006SchemaContext.GetXamlType(Int16 typeId)
at System.Windows.Baml2006.Baml2006Reader.Process_ElementStart()
at System.Windows.Baml2006.Baml2006Reader.Process_OneBamlRecord()
at System.Windows.Baml2006.Baml2006Reader.Process_BamlRecords()
at System.Windows.Baml2006.Baml2006Reader.Read()
at System.Windows.Markup.WpfXamlLoader.TransformNodes(XamlReader xamlReader, XamlObjectWriter xamlWriter, Boolean onlyLoadOneNode, Boolean skipJournaledProperties, Boolean shouldPassLineNumberInfo, IXamlLineInfo xamlLineInfo, IXamlLineInfoConsumer xamlLineInfoConsumer, XamlContextStack`1 stack, IStyleConnector styleConnector)
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
--- End of inner exception stack trace ---
at System.Windows.Markup.XamlReader.RewrapException(Exception e, IXamlLineInfo lineInfo, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
at System.Windows.Application.LoadBamlStreamWithSyncInfo(Stream stream, ParserContext pc)
at System.Windows.Application.LoadComponent(Uri resourceLocator, Boolean bSkipJournaledProperties)
at System.Windows.Application.DoStartup()
at System.Windows.Application.<.ctor>b__1(Object unused)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)

any help will be appreciated

best regards
Coordinator
Apr 19, 2014 at 4:29 PM
Edited Apr 19, 2014 at 4:30 PM
Trace?
If you don't know how to dump messages produced by trace, use TraceTool.
Coordinator
Apr 24, 2014 at 8:31 AM
Might be identical to issue #7. Resolved in 1.1.0.2.
Apr 27, 2014 at 2:03 PM
Edited Apr 27, 2014 at 2:04 PM
I have the same problem with v 1.1.0.2.
Also I don't have HKLM\Software\Softpark\LibZ, HKCU\Software\Softpark\LibZ keys ?

I have tried instrument my assembly on another machine I got this exception:
libz instrument --assembly myapplication.exe --libz-file wpf.libz
LibZ 1.1.0.2, Copyright (c) 2013-2014, Milosz Krajewski
https://libz.codeplex.com/

Registering codec 'doboz'
Doboz initialized as 'Unsafe'
Registering codec 'lz4'
LZ4 initialized as 'Unsafe 32/Unsafe 64/Unsafe 32HC'

Executing instrument (Instruments assembly with initialization code):

Loading 'myapplication.exe'
Loaded 'myapplication, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null
'
LibZResolver has been found embedded into main executable
Loading assembly from resources
Loaded 'LibZ.Injected, Version=1.1.0.2, Culture=neutral, PublicKeyToken=null'
Saving 'myapplication.exe'

Unhandled Exception: System.DllNotFoundException: Unable to load DLL 'MSVCR100.dll': Le module spécifié est introuvable. (Exception from HRESULT: 0x8007007E)
at _encoded_null()
at _app_exit_callback()
at <CrtImplementationDetails>.LanguageSupport.DomainUnload(Object source, EventArgs arguments)
at <CrtImplementationDetails>.ModuleUninitializer.SingletonDomainUnload(Object source, EventArgs arguments)
Coordinator
Apr 27, 2014 at 7:45 PM
There are multiple things here.
  • The 'MSVCR100.dll' problem is related to missing Visual C++ 2010 Redistributable missing from the 'other' machine. Install it or delete lz4.libzcodec. Anyway, the embedding worked fine (this exception was throw on exit and is not related).
  • Your initial problem still remains a mystery. Can you send me (PM + dropbox) your assemblies and a script you use to merge them? What about trace?
May 6, 2014 at 9:39 AM
Edited May 6, 2014 at 9:40 AM
Hi Krashan,

My initial problem was related to applying devexpress themes in Xaml like this:
dx:ThemeManager.ThemeName="Office2010Silver"

I resolved it partially, given that when I apply a theme using code behind (ThemeManager.ApplicationThemeName = Theme.Office2010SilverName) for example, the theme will not be applied on Gridcontrols (Datagrid) ? do you have experienced this kind of issues?

best regards,

Rosen
Coordinator
May 7, 2014 at 9:33 AM
Not really. I mean all the exception related to embedding assemblies manifest themselves as "FileNotFoundException". As .NET tries to load assembly and cannot find it. This one is "System.Windows.Markup.XamlParseException". It might, of course, related but it is nothing obvious. I haven't seen anything like this before.